OS: All platforms


Problem Description


When performing a backup of any type, the following error message is received in the backup report: 

No.TypeTimestampLog
*infoYYYY/MM/DD hh:mm:ssStart running pre-commands
*.........
*erroYYYY/MM/DD hh:mm:ssUnable to do backup, Error= [BlockDB.init] Error initializing bptree
*.........


Cause


This issue can occurs if the index file on the client computer is corrupted.

For example, if the previous backup job was ended abruptly (e.g. client computer crash, application crash) resulting in the index file being corrupted.


Resolution


To resolve the issue, manually delete the index files on the client computer: 

  1. Ensure that no backup / restore job is running. 
  2. Ensure that the AhsayOBM / ACB client user interface is not opened. 
  3. Delete the contents in the temporary directory configured for the affected backup set:

    ${temp_directory}\${backupset_id}\OBS@id

    Note:
    temp_directory is the temporary directory configured for the affected backup set.
     

  4. Login to the AhsayOBM / ACB client application to start another backup job afterward.